const regex = /^(.*? (?:VAN|VON|DE)) |((?<!^)\G\w+) /gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*? (?:VAN|VON|DE)) |((?<!^)\\G\\w+) ', 'gim')
const str = `ANNEKA VANHOVEN BAKKER
HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
JOHN SMITH`;
const subst = `$1$2-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);