#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)Medfinansiering: *([^\r\n]+)\r?\n.*?(somatisk tillstånd.*)(?=Kommande)"
Local $sString = "Medfinansiering: Ja: Studiebesök" & @CRLF & _
" Övriga synpunkter: Vi skulle anställa från Hermods YH utbildning som denna för den" & @CRLF & _
"är bred och ger oss kompetent personal med helhetssyn och" & @CRLF & _
" kunskap om somatisk tillstånd, det är den delen som man saknar" & @CRLF & _
" idag. Kommande pensionsavgångar leder till att vi behöver" & @CRLF & _
" nyrekrytera och den andra hälften av rekryteringsbehovet beror" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")