# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)Medfinansiering: *([^\r\n]+)\r?\n.*?(somatisk tillstånd.*)(?=Kommande)"
test_str = ("Medfinansiering: Ja: Studiebesök\n"
" Övriga synpunkter: Vi skulle anställa från Hermods YH utbildning som denna för den\n"
"är bred och ger oss kompetent personal med helhetssyn och\n"
" kunskap om somatisk tillstånd, det är den delen som man saknar\n"
" idag. Kommande pensionsavgångar leder till att vi behöver\n"
" nyrekrytera och den andra hälften av rekryteringsbehovet beror\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.