import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)Medfinansiering: *([^\\r\\n]+)\\r?\\n.*?(somatisk tillstånd.*)(?=Kommande)";
final String string = "Medfinansiering: Ja: Studiebesök\n"
+ " Övriga synpunkter: Vi skulle anställa från Hermods YH utbildning som denna för den\n"
+ "är bred och ger oss kompetent personal med helhetssyn och\n"
+ " kunskap om somatisk tillstånd, det är den delen som man saknar\n"
+ " idag. Kommande pensionsavgångar leder till att vi behöver\n"
+ " nyrekrytera och den andra hälften av rekryteringsbehovet beror\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}