import Foundation
let pattern = #"(?s)Medfinansiering: *([^\r\n]+)\r?\n.*?(somatisk tillstånd.*)(?=Kommande)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Medfinansiering: Ja: Studiebesök
Övriga synpunkter: Vi skulle anställa från Hermods YH utbildning som denna för den
är bred och ger oss kompetent personal med helhetssyn och
kunskap om somatisk tillstånd, det är den delen som man saknar
idag. Kommande pensionsavgångar leder till att vi behöver
nyrekrytera och den andra hälften av rekryteringsbehovet beror
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)