using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)Medfinansiering: *([^\r\n]+)\r?\n.*?(somatisk tillstånd.*)(?=Kommande)";
string input = @"Medfinansiering: Ja: Studiebesök
Övriga synpunkter: Vi skulle anställa från Hermods YH utbildning som denna för den
är bred och ger oss kompetent personal med helhetssyn och
kunskap om somatisk tillstånd, det är den delen som man saknar
idag. Kommande pensionsavgångar leder till att vi behöver
nyrekrytera och den andra hälften av rekryteringsbehovet beror
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}