const regex = /(?s)Medfinansiering: *([^\r\n]+)\r?\n.*?(somatisk tillstånd.*)(?=Kommande)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)Medfinansiering: *([^\\r\\n]+)\\r?\\n.*?(somatisk tillstånd.*)(?=Kommande)', 'gm')
const str = `Medfinansiering: Ja: Studiebesök
Övriga synpunkter: Vi skulle anställa från Hermods YH utbildning som denna för den
är bred och ger oss kompetent personal med helhetssyn och
kunskap om somatisk tillstånd, det är den delen som man saknar
idag. Kommande pensionsavgångar leder till att vi behöver
nyrekrytera och den andra hälften av rekryteringsbehovet beror
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}