re = /(?s)Medfinansiering: *([^\r\n]+)\r?\n.*?(somatisk tillstånd.*)(?=Kommande)/m
str = 'Medfinansiering: Ja: Studiebesök
Övriga synpunkter: Vi skulle anställa från Hermods YH utbildning som denna för den
är bred och ger oss kompetent personal med helhetssyn och
kunskap om somatisk tillstånd, det är den delen som man saknar
idag. Kommande pensionsavgångar leder till att vi behöver
nyrekrytera och den andra hälften av rekryteringsbehovet beror
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end