import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^@\\s]+@[^@\\s]+\\.[a-z]{2,}$";
final String string = "I want to check email format like\n"
+ "email : \n"
+ "Heythere123@something.com\n"
+ " // passed\n"
+ "but \n"
+ "email: \n"
+ "Heythere123@something.com2222\n"
+ " // should not pass\n"
+ "email: \n"
+ "Heythere123@something.com#$@!\n"
+ " // shuuld not pass";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}