$re = '/^[^@\s]+@[^@\s]+\.[a-z]{2,}$/m';
$str = 'I want to check email format like
email :
Heythere123@something.com
// passed
but
email:
Heythere123@something.com2222
// should not pass
email:
Heythere123@something.com#$@!
// shuuld not pass';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);