// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^@\s]+@[^@\s]+\.[a-z]{2,}$").unwrap();
let string = "I want to check email format like
email :
Heythere123@something.com
// passed
but
email:
Heythere123@something.com2222
// should not pass
email:
Heythere123@something.com#$@!
// shuuld not pass";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}