import re
regex = re.compile(r"^[^@\s]+@[^@\s]+\.[a-z]{2,}$", flags=re.MULTILINE)
test_str = ("I want to check email format like\n"
"email : \n"
"Heythere123@something.com\n"
" // passed\n"
"but \n"
"email: \n"
"Heythere123@something.com2222\n"
" // should not pass\n"
"email: \n"
"Heythere123@something.com#$@!\n"
" // shuuld not pass")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")