const regex = /^[^@\s]+@[^@\s]+\.[a-z]{2,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^@\\s]+@[^@\\s]+\\.[a-z]{2,}$', 'gm')
const str = `I want to check email format like
email :
Heythere123@something.com
// passed
but
email:
Heythere123@something.com2222
// should not pass
email:
Heythere123@something.com#\$@!
// shuuld not pass`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}