re = /^[^@\s]+@[^@\s]+\.[a-z]{2,}$/m
str = 'I want to check email format like
email :
Heythere123@something.com
// passed
but
email:
Heythere123@something.com2222
// should not pass
email:
Heythere123@something.com#$@!
// shuuld not pass'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end