using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.{2,100}$)[^\W\d_]{2,}(?:[-\s][^\W\d_]{2,})*";
string input = @"########################### valid names ##############################
Peter
Hans-Peter
Hector Sausage-Hausen
Alexander Groß
àáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇ
Martin Luther King Jr
Martin Luther King Jr.
Saäüößin
Älbert
Ülbert
Ölbert
Mo
Mathias d'Arras
Mike O'Neal
Peter.
Peter?
Peter!
Boby-Dick.
Boby-Dick?
Boby-Dick!
########################### not valid names ###########################
Peter123
Stev3 Smith
Steve Sm1th
Peter...
Max!""§$%&/()
Max_
M
Peter?!?
Peter(
(Peter)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}