# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=.{2,100}$)[^\W\d_]{2,}(?:[-\s][^\W\d_]{2,})*"
test_str = ("########################### valid names ##############################\n\n"
"Peter\n"
"Hans-Peter\n"
"Hector Sausage-Hausen\n"
"Alexander Groß\n"
"àáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇ\n"
"Martin Luther King Jr\n"
"Martin Luther King Jr.\n"
"Saäüößin\n"
"Älbert\n"
"Ülbert\n"
"Ölbert\n"
"Mo\n\n\n\n"
"Mathias d'Arras\n"
"Mike O'Neal\n\n"
"Peter.\n"
"Peter?\n"
"Peter!\n"
"Boby-Dick.\n"
"Boby-Dick?\n"
"Boby-Dick!\n\n\n"
"########################### not valid names ###########################\n"
"Peter123\n"
"Stev3 Smith\n"
"Steve Sm1th \n"
"Peter...\n"
"Max!\"§$%&/()\n"
"Max_\n"
"M\n"
"Peter?!?\n"
"Peter(\n"
"(Peter)\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.