const regex = new RegExp('(?=.{2,100}$)[^\\W\\d_]{2,}(?:[-\\s][^\\W\\d_]{2,})*', 'gm')
const str = `########################### valid names ##############################
Peter
Hans-Peter
Hector Sausage-Hausen
Alexander Groß
àáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇ
Martin Luther King Jr
Martin Luther King Jr.
Saäüößin
Älbert
Ülbert
Ölbert
Mo
Mathias d'Arras
Mike O'Neal
Peter.
Peter?
Peter!
Boby-Dick.
Boby-Dick?
Boby-Dick!
########################### not valid names ###########################
Peter123
Stev3 Smith
Steve Sm1th
Peter...
Max!"§\$%&/()
Max_
M
Peter?!?
Peter(
(Peter)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}