import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.{2,100}$)[^\\W\\d_]{2,}(?:[-\\s][^\\W\\d_]{2,})*";
final String string = "########################### valid names ##############################\n\n"
+ "Peter\n"
+ "Hans-Peter\n"
+ "Hector Sausage-Hausen\n"
+ "Alexander Groß\n"
+ "àáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇ\n"
+ "Martin Luther King Jr\n"
+ "Martin Luther King Jr.\n"
+ "Saäüößin\n"
+ "Älbert\n"
+ "Ülbert\n"
+ "Ölbert\n"
+ "Mo\n\n\n\n"
+ "Mathias d'Arras\n"
+ "Mike O'Neal\n\n"
+ "Peter.\n"
+ "Peter?\n"
+ "Peter!\n"
+ "Boby-Dick.\n"
+ "Boby-Dick?\n"
+ "Boby-Dick!\n\n\n"
+ "########################### not valid names ###########################\n"
+ "Peter123\n"
+ "Stev3 Smith\n"
+ "Steve Sm1th \n"
+ "Peter...\n"
+ "Max!\"§$%&/()\n"
+ "Max_\n"
+ "M\n"
+ "Peter?!?\n"
+ "Peter(\n"
+ "(Peter)\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}