use strict;
my $str = '########################### valid names ##############################
Peter
Hans-Peter
Hector Sausage-Hausen
Alexander Groß
àáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇ
Martin Luther King Jr
Martin Luther King Jr.
Saäüößin
Älbert
Ülbert
Ölbert
Mo
Mathias d\'Arras
Mike O\'Neal
Peter.
Peter?
Peter!
Boby-Dick.
Boby-Dick?
Boby-Dick!
########################### not valid names ###########################
Peter123
Stev3 Smith
Steve Sm1th
Peter...
Max!"§$%&/()
Max_
M
Peter?!?
Peter(
(Peter)
';
my $regex = qr/(?=.{2,100}$)[^\W\d_]{2,}(?:[-\s][^\W\d_]{2,})*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}