import Foundation
let pattern = #"(?=.{2,100}$)[^\W\d_]{2,}(?:[-\s][^\W\d_]{2,})*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###############################"""
########################### valid names ##############################
Peter
Hans-Peter
Hector Sausage-Hausen
Alexander Groß
àáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇ
Martin Luther King Jr
Martin Luther King Jr.
Saäüößin
Älbert
Ülbert
Ölbert
Mo
Mathias d'Arras
Mike O'Neal
Peter.
Peter?
Peter!
Boby-Dick.
Boby-Dick?
Boby-Dick!
########################### not valid names ###########################
Peter123
Stev3 Smith
Steve Sm1th
Peter...
Max!"§$%&/()
Max_
M
Peter?!?
Peter(
(Peter)
"""###############################
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)