re = /(?=.{2,100}$)[^\W\d_]{2,}(?:[-\s][^\W\d_]{2,})*/m
str = '########################### valid names ##############################
Peter
Hans-Peter
Hector Sausage-Hausen
Alexander Groß
àáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇ
Martin Luther King Jr
Martin Luther King Jr.
Saäüößin
Älbert
Ülbert
Ölbert
Mo
Mathias d\'Arras
Mike O\'Neal
Peter.
Peter?
Peter!
Boby-Dick.
Boby-Dick?
Boby-Dick!
########################### not valid names ###########################
Peter123
Stev3 Smith
Steve Sm1th
Peter...
Max!"§$%&/()
Max_
M
Peter?!?
Peter(
(Peter)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end