#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[ ]*((озу|ОЗУ)[:]{0,1}[ ]*)(?<OZU>[А-Яа-я0-9 .,]*)$"
Local $sString = " озу: водоохранные зоны" & @CRLF & _
"озу: ДРУГИЕ ОСОБО ЗАЩИТНЫЕ УЧАСТКИ" & @CRLF & _
"озу: УЧАСТКИ ЛЕСА ВОКРУГ СЕЛЬСКИХ НАСЕЛЕННЫХ ПУНКТОВ" & @CRLF & _
"озу: ВОДООХРАННЫЕ ЗОНЫ И ПРИБРЕЖНЫЕ ЗАЩИТНЫЕ ПОЛОСЫ" & @CRLF & _
"озу: 100М ОПУШКИ ВДОЛЬ ДОРОГ" & @CRLF & _
"озу: ПАМЯТНИКИ ПРИРОДЫ" & @CRLF & _
"озу: водоохранные зоны" & @CRLF & _
"озу: участки леса на крутых горных склонах" & @CRLF & _
"озу: участки леса с наличием ценных пород" & @CRLF & _
"озу: кедровый стланик" & @CRLF & _
"озу: медоносные участки лесов" & @CRLF & _
"озу: лесосеменные участки" & @CRLF & _
"озу: участки леса среди безлесных пространств" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")