import Foundation
let pattern = #"^[ ]*((озу|ОЗУ)[:]{0,1}[ ]*)(?<OZU>[А-Яа-я0-9 .,]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
озу: водоохранные зоны
озу: ДРУГИЕ ОСОБО ЗАЩИТНЫЕ УЧАСТКИ
озу: УЧАСТКИ ЛЕСА ВОКРУГ СЕЛЬСКИХ НАСЕЛЕННЫХ ПУНКТОВ
озу: ВОДООХРАННЫЕ ЗОНЫ И ПРИБРЕЖНЫЕ ЗАЩИТНЫЕ ПОЛОСЫ
озу: 100М ОПУШКИ ВДОЛЬ ДОРОГ
озу: ПАМЯТНИКИ ПРИРОДЫ
озу: водоохранные зоны
озу: участки леса на крутых горных склонах
озу: участки леса с наличием ценных пород
озу: кедровый стланик
озу: медоносные участки лесов
озу: лесосеменные участки
озу: участки леса среди безлесных пространств
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)