using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ ]*((озу|ОЗУ)[:]{0,1}[ ]*)(?<OZU>[А-Яа-я0-9 .,]*)$";
string input = @" озу: водоохранные зоны
озу: ДРУГИЕ ОСОБО ЗАЩИТНЫЕ УЧАСТКИ
озу: УЧАСТКИ ЛЕСА ВОКРУГ СЕЛЬСКИХ НАСЕЛЕННЫХ ПУНКТОВ
озу: ВОДООХРАННЫЕ ЗОНЫ И ПРИБРЕЖНЫЕ ЗАЩИТНЫЕ ПОЛОСЫ
озу: 100М ОПУШКИ ВДОЛЬ ДОРОГ
озу: ПАМЯТНИКИ ПРИРОДЫ
озу: водоохранные зоны
озу: участки леса на крутых горных склонах
озу: участки леса с наличием ценных пород
озу: кедровый стланик
озу: медоносные участки лесов
озу: лесосеменные участки
озу: участки леса среди безлесных пространств
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}