import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ ]*((озу|ОЗУ)[:]{0,1}[ ]*)(?<OZU>[А-Яа-я0-9 .,]*)$";
final String string = " озу: водоохранные зоны\n"
+ "озу: ДРУГИЕ ОСОБО ЗАЩИТНЫЕ УЧАСТКИ\n"
+ "озу: УЧАСТКИ ЛЕСА ВОКРУГ СЕЛЬСКИХ НАСЕЛЕННЫХ ПУНКТОВ\n"
+ "озу: ВОДООХРАННЫЕ ЗОНЫ И ПРИБРЕЖНЫЕ ЗАЩИТНЫЕ ПОЛОСЫ\n"
+ "озу: 100М ОПУШКИ ВДОЛЬ ДОРОГ\n"
+ "озу: ПАМЯТНИКИ ПРИРОДЫ\n"
+ "озу: водоохранные зоны\n"
+ "озу: участки леса на крутых горных склонах\n"
+ "озу: участки леса с наличием ценных пород\n"
+ "озу: кедровый стланик\n"
+ "озу: медоносные участки лесов\n"
+ "озу: лесосеменные участки\n"
+ "озу: участки леса среди безлесных пространств\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}