// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[ ]*((озу|ОЗУ)[:]{0,1}[ ]*)(?<OZU>[А-Яа-я0-9 .,]*)$").unwrap();
let string = " озу: водоохранные зоны
озу: ДРУГИЕ ОСОБО ЗАЩИТНЫЕ УЧАСТКИ
озу: УЧАСТКИ ЛЕСА ВОКРУГ СЕЛЬСКИХ НАСЕЛЕННЫХ ПУНКТОВ
озу: ВОДООХРАННЫЕ ЗОНЫ И ПРИБРЕЖНЫЕ ЗАЩИТНЫЕ ПОЛОСЫ
озу: 100М ОПУШКИ ВДОЛЬ ДОРОГ
озу: ПАМЯТНИКИ ПРИРОДЫ
озу: водоохранные зоны
озу: участки леса на крутых горных склонах
озу: участки леса с наличием ценных пород
озу: кедровый стланик
озу: медоносные участки лесов
озу: лесосеменные участки
озу: участки леса среди безлесных пространств
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}