package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[ ]*((озу|ОЗУ)[:]{0,1}[ ]*)(?<OZU>[А-Яа-я0-9 .,]*)$`)
var str = ` озу: водоохранные зоны
озу: ДРУГИЕ ОСОБО ЗАЩИТНЫЕ УЧАСТКИ
озу: УЧАСТКИ ЛЕСА ВОКРУГ СЕЛЬСКИХ НАСЕЛЕННЫХ ПУНКТОВ
озу: ВОДООХРАННЫЕ ЗОНЫ И ПРИБРЕЖНЫЕ ЗАЩИТНЫЕ ПОЛОСЫ
озу: 100М ОПУШКИ ВДОЛЬ ДОРОГ
озу: ПАМЯТНИКИ ПРИРОДЫ
озу: водоохранные зоны
озу: участки леса на крутых горных склонах
озу: участки леса с наличием ценных пород
озу: кедровый стланик
озу: медоносные участки лесов
озу: лесосеменные участки
озу: участки леса среди безлесных пространств
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}