#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[^:]*:){2}(*SKIP)(?!)|:"
Local $sString = ":account_id:12345:6789:Melbourne:Aus" & @CRLF & _
":account_id:98765:43210:Adelaide:Aus"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)