$re = '/^(?:[^:]*:){2}(*SKIP)(?!)|:/m';
$str = ':account_id:12345:6789:Melbourne:Aus
:account_id:98765:43210:Adelaide:Aus';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;