const regex = /^(?:[^:]*:){2}(*SKIP)(?!)|:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^:]*:){2}(*SKIP)(?!)|:', 'gm')
const str = `:account_id:12345:6789:Melbourne:Aus
:account_id:98765:43210:Adelaide:Aus`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);