import re
regex = re.compile(r"^(?:[^:]*:){2}(*SKIP)(?!)|:", flags=re.MULTILINE)
test_str = (":account_id:12345:6789:Melbourne:Aus\n"
":account_id:98765:43210:Adelaide:Aus")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)