#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\<ns1:tag\>(.*)\<\/ns1:tag\>"
Local $sString = "<sometag>" & @CRLF & _
"<ns1:tag>120</ns1:tag>" & @CRLF & _
"<ns2:tag>0</ns2:tag>" & @CRLF & _
"</sometag>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")