$re = '/\<ns1:tag\>(.*)\<\/ns1:tag\>/m';
$str = '<sometag>
<ns1:tag>120</ns1:tag>
<ns2:tag>0</ns2:tag>
</sometag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);