re = /\<ns1:tag\>(.*)\<\/ns1:tag\>/m
str = '<sometag>
<ns1:tag>120</ns1:tag>
<ns2:tag>0</ns2:tag>
</sometag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end