import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<ns1:tag\\>(.*)\\<\\/ns1:tag\\>";
final String string = "<sometag>\n"
+ "<ns1:tag>120</ns1:tag>\n"
+ "<ns2:tag>0</ns2:tag>\n"
+ "</sometag>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}