const regex = /\<ns1:tag\>(.*)\<\/ns1:tag\>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<ns1:tag\\>(.*)\\<\\\/ns1:tag\\>', 'gm')
const str = `<sometag>
<ns1:tag>120</ns1:tag>
<ns2:tag>0</ns2:tag>
</sometag>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}