// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\<ns1:tag\>(.*)\<\/ns1:tag\>").unwrap();
let string = "<sometag>
<ns1:tag>120</ns1:tag>
<ns2:tag>0</ns2:tag>
</sometag>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}