package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\<ns1:tag\>(.*)\<\/ns1:tag\>`)
var str = `<sometag>
<ns1:tag>120</ns1:tag>
<ns2:tag>0</ns2:tag>
</sometag>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}