#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[1-9]([A-Z&&[^SLOIBZ]][0-9A-Z&&[^SLOIBZ]]\d){2}[A-Z&&[^SLOIBZ]]{2}\d{2}"
Local $sString = "1EG4TE5MK72" & @CRLF & _
"1EG4TE5MK73" & @CRLF & _
"0EG4TE5MK73" & @CRLF & _
"1LG4TE5MK73" & @CRLF & _
"1eG4TE5MK73" & @CRLF & _
"123456789T" & @CRLF & _
"123456789A1" & @CRLF & _
"1E04T95MK73"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")