// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[1-9]([A-Z&&[^SLOIBZ]][0-9A-Z&&[^SLOIBZ]]\d){2}[A-Z&&[^SLOIBZ]]{2}\d{2}").unwrap();
let string = "1EG4TE5MK72
1EG4TE5MK73
0EG4TE5MK73
1LG4TE5MK73
1eG4TE5MK73
123456789T
123456789A1
1E04T95MK73";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}