const regex = new RegExp('[1-9]([A-Z&&[^SLOIBZ]][0-9A-Z&&[^SLOIBZ]]\\d){2}[A-Z&&[^SLOIBZ]]{2}\\d{2}', 'i')
const str = `1EG4TE5MK72
1EG4TE5MK73
0EG4TE5MK73
1LG4TE5MK73
1eG4TE5MK73
123456789T
123456789A1
1E04T95MK73`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}