re = /[1-9]([A-Z&&[^SLOIBZ]][0-9A-Z&&[^SLOIBZ]]\d){2}[A-Z&&[^SLOIBZ]]{2}\d{2}/i
str = '1EG4TE5MK72
1EG4TE5MK73
0EG4TE5MK73
1LG4TE5MK73
1eG4TE5MK73
123456789T
123456789A1
1E04T95MK73'
# Print the match result
str.match(re) do |match|
puts match.to_s
end