package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[1-9]([A-Z&&[^SLOIBZ]][0-9A-Z&&[^SLOIBZ]]\d){2}[A-Z&&[^SLOIBZ]]{2}\d{2}`)
var str = `1EG4TE5MK72
1EG4TE5MK73
0EG4TE5MK73
1LG4TE5MK73
1eG4TE5MK73
123456789T
123456789A1
1E04T95MK73`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}