import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[1-9]([A-Z&&[^SLOIBZ]][0-9A-Z&&[^SLOIBZ]]\\d){2}[A-Z&&[^SLOIBZ]]{2}\\d{2}";
final String string = "1EG4TE5MK72\n"
+ "1EG4TE5MK73\n"
+ "0EG4TE5MK73\n"
+ "1LG4TE5MK73\n"
+ "1eG4TE5MK73\n"
+ "123456789T\n"
+ "123456789A1\n"
+ "1E04T95MK73";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}