#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]\d{8}(?:,[1-9]\d{8})+$"
Local $sString = "923456789" & @CRLF & _
"123456789,923456789" & @CRLF & _
"123456789,923456789,923456489" & @CRLF & _
",923456789" & @CRLF & _
",92345678" & @CRLF & _
"9234567d3" & @CRLF & _
"023456789,923456789" & @CRLF & _
"723456789,92345678,333333"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")