re = /^[1-9]\d{8}(?:,[1-9]\d{8})+$/m
str = '923456789
123456789,923456789
123456789,923456789,923456489
,923456789
,92345678
9234567d3
023456789,923456789
723456789,92345678,333333'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end