import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]\\d{8}(?:,[1-9]\\d{8})+$";
final String string = "923456789\n"
+ "123456789,923456789\n"
+ "123456789,923456789,923456489\n"
+ ",923456789\n"
+ ",92345678\n"
+ "9234567d3\n"
+ "023456789,923456789\n"
+ "723456789,92345678,333333";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}