using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]\d{8}(?:,[1-9]\d{8})+$";
string input = @"923456789
123456789,923456789
123456789,923456789,923456489
,923456789
,92345678
9234567d3
023456789,923456789
723456789,92345678,333333";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}