use strict;
my $str = '923456789
123456789,923456789
123456789,923456789,923456489
,923456789
,92345678
9234567d3
023456789,923456789
723456789,92345678,333333';
my $regex = qr/^[1-9]\d{8}(?:,[1-9]\d{8})+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}