const regex = /^[1-9]\d{8}(?:,[1-9]\d{8})+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]\\d{8}(?:,[1-9]\\d{8})+$', 'gm')
const str = `923456789
123456789,923456789
123456789,923456789,923456489
,923456789
,92345678
9234567d3
023456789,923456789
723456789,92345678,333333`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}